Nach Update auf Version 2.4.1 keine Internetverbindung per PPPoE mehr möglich

Jürgen Mainka
01.11.2017 14:26

Wird die pfSense auf Version 2.4.1 aktualisiert, kann es unter Umständen dazu kommen, dass eine WAN- bzw. Internetverbindung per PPPoE nicht mehr möglich ist. Dies tritt meist bei VDSL-Anschlüssen auf, die mit VLANs eingerichtet sind.

Der Fehler ist bereits beim pfSense-Team auf der ToDo-Liste und wird voraussichtlich zur Version 2.4.2 beseitigt sein. Um die pfSense auch mit der 2.4.1 wieder zur Mitarbeit zu bewegen, sind einige kurze Eingriffe in die Datei /conf/config.xml notwendig. Ein aufwändiges Zurückgehen auf die 2.4.0 bleibt somit erspart.

Um die Internetverbindung wieder zum Laufen zu bringen, wie folgt vorgehen:

  1. Mit dem Webbrowser an der pfSense anmelden.
  2. Im Menü auf Diagnostics→Edit File gehen.
  3. Mittels Browse die Datei /conf/config.xml zur Bearbeitung auswählen.
  4. Nun in der Datei nach dem VLAN-Interface für die PPPoE-Verbindung suchen, z.B. "em0.7" (VLAN 7 gilt für Telekom-Anschlüsse).
    Dies findet sich jeweils im Abschnitt ppps/ppp und vlans/vlan der XML-Konfigurationsdatei.
  5. Alle Angaben zu dem VLAN-Interface müssen nun so umbenannt werden, dass aus dem Punkt ein Unterstrich wird, also z.B. aus "em0.7" wird "em0_7".
  6. Die Datei config.xml nach den Änderungen speichern und pfSense neu starten.

Sind weitere VLANs, wie z.B. für Entertain der Telekom eingerichtet, so bleibt dieses VLAN unangetastet!

Die Probleme mit dem VLAN treten laut Nutzermeldungen nur bei VLANs in Verbindung mit der PPPoE-Verbindung auf!

Links

Tags: pfsense, pppoe, vlan
Durchschnittliche Bewertung: 5 (1 Abstimmung)

Kommentieren nicht möglich